4

On two different computers I use, both running recent Firefox, this site's Gatherer links open non-scrolling windows. The windows both have no scroll bar and can't be scrolled by arrow keys / mouse wheel.

If I do "open link in new tab" or navigate Gatherer manually without using links from B&CG, I get no such problems.

No scrolling is a big deal because it's a terrible UI experience that makes it functionally impossible to see full Oracle text for cards.

Try it:

Yidris, Maelstrom Wielder

vs.

Direct link

| |
  • I'm fine with "switch to Scryfall" as the answer if that actually happens. If not, we need to fix this. boardgames.meta.stackexchange.com/questions/1652/… – Alex P Jan 15 '18 at 19:23
  • bug seems to be in IE as well, but can't replicate in Chrome. Autocard frustrations seems to be growing, I am all for a switch to Scryfall if it fixes things as well. – Malco Jan 15 '18 at 22:19
  • @Malco I suspect the bug may be a by-design feature of WotC's javascript thing following 2005-ish web design conventions. (And Chrome just doesn't honor it because, enh, why would you?) – Alex P Jan 15 '18 at 22:43
  • 1
    Yes, this is by design. I'd agree with you that it's pretty bad design, but still, somebody at some point must have thought it was a good idea to add scrollbars=0 (and resizable=0) to the window.open() call. <plug>As it happens, my SOUP user script fixes this, as a side effect of rewriting the [mtg:...] links to use Scryfall instead.</plug> – Ilmari Karonen Jan 28 '18 at 2:46
2

Fix mtg.js

Note the JavaScript script we're using for autocard links (thanks to Ilmari Karonen for catching this):

window.open(link, "autocard" + (+new Date()), "toolbar=0, location=0, directories=0, status=0,menubar=0, scrollbars=0, resizable=0, width=770, height=890");

We should clean this up to link to Gatherer in a more "normal" style (just remove some of the forced styling and let the browser manage it) instead.

| |
  • That feature is only supported by IE, Firefox and Opera which is why you have the issue in firefox and I don't in chrome. – Joe W Jan 30 '18 at 15:00
  • 1
    Actually it may not be supported by IE or Opera anymore which leaves just Firefox with this problem – Joe W Jan 30 '18 at 15:20
0

That sounds like it might be a bug with firefox as when I open any gatherer link in chrome it opens with scroll bars as expected including the one you linked in your question.

| |
  • I think that's Chrome rejecting the window settings because it thinks the settings are dumb. – Alex P Jan 30 '18 at 9:26
  • Adding scroll bars to windows that do not show the entire content is expected of browsers (and all other programs) and something that you would have to deliberately work around which I don't think this site is doing. – Joe W Jan 30 '18 at 13:39
  • That's what "scrollbars=0" is doing. – Alex P Jan 30 '18 at 14:03
  • 1
    After looking into it more I think Firefox is the only browser that supports that setting which would make it a bug with Firefox imo. – Joe W Jan 30 '18 at 15:21
  • Interesting find, Joe. – Alex P Jan 30 '18 at 15:30

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .